查看: 33|回复: 0

Discuz PHP Deprecated: __autoload() is deprecated in PHP 7.2

[复制链接]

18

主题

18

帖子

73

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
73
发表于 2018-5-3 15:27:38 | 显示全部楼层 |阅读模式
今天下载的最新的discuz,刚刚安装后出现的问题,无法登录,如图:
1111.png
错误代码
  1. Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /www/wwwroot/bbs.baymw.com/source/class/class_core.php on line 27
复制代码
找到文件source\class\class_core.php,用文件编辑软件打开,搜索 或者直接定位到第27行
  1. if(function_exists('spl_autoload_register')) {
  2.         spl_autoload_register(array('core', 'autoload'));
  3. } else {
  4.         function __autoload($class) {
  5.                 return core::autoload($class);
  6.         }
  7. }
复制代码
将else部分删除,变成
  1. if(function_exists('spl_autoload_register')) {
  2.         spl_autoload_register(array('core', 'autoload'));
  3. }
复制代码
附带修改好的懒人包
class_core.zip (1.84 KB, 下载次数: 5)
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则 返回列表 发新帖

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

快速回复 返回顶部 返回列表